Unscheduled Maintenance
Incident Report for Lykke
Update
We are continuing to investigate this issue.
Posted Jun 06, 2024 - 20:22 UTC
Investigating
We are currently investigating this issue.
Posted Jun 06, 2024 - 10:00 UTC
This incident affects: Lykke Exchange, Lykke Wallet, Trading API, Fiat payment gateway, and Blockchain deposit/withdrawal.