Unscheduled maintenance
Incident Report for Lykke
Resolved
This incident has been resolved.
Posted Nov 27, 2020 - 19:24 UTC
Investigating
Dash deposits and withdrawals are temporary unavailable to update the node. We apologize for any inconvenience caused. ETA is approximately 24 hours.
Posted Nov 27, 2020 - 08:58 UTC
This incident affected: Blockchain deposit/withdrawal.