BTG service issues
Incident Report for Lykke
Resolved
This incident has been resolved.
Posted about 2 months ago. Jun 29, 2018 - 18:05 UTC
Identified
We are currently facing technical difficulties with BTG service. BTG withdrawals are disabled until further notice. Solution ETA - within today. We apologize for the inconveniences.
Posted about 2 months ago. Jun 29, 2018 - 11:40 UTC
This incident affected: Blockchain deposit/withdrawal.