MothershipMSP ‏withdrawals, deposits and trading disabled
Incident Report for Lykke
Resolved
This incident has been resolved.
Posted Sep 20, 2019 - 18:52 UTC
Update
We are continuing to work on this issue.
Posted Jan 29, 2019 - 09:47 UTC
Identified
Due to the recent Cryptopia exchange hack, MothershipMSP trading, deposits and withdrawals have been disabled upon the request by MothershipMSP. We will keep the MothershipMSP token holders updated.
Posted Jan 22, 2019 - 14:09 UTC
This incident affected: Blockchain deposit/withdrawal.